Red X where Chart should be

Sep 21, 2009 at 8:02 PM

I installed all the pieces and corrected some changes which broke web.config. I can configure the web part and tie it to a list, but the chart just shows a red x. Ideas?

Coordinator
Sep 22, 2009 at 5:55 AM

Ok,

first of all what did you change in web.config?

Second; verify that you have these lines in your web.config:

<add verb="*" path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral,PublicKeyToken=31bf3856ad364e35" validate="false" />
...
<add key="ChartImageHandler" value="storage=memory;timeout=20;" />

/WW

Sep 22, 2009 at 1:17 PM

I had to remove a duplicated sectiongroup for system.web.extensions.

The verb line was not present in the web config. I added it and now the chart is displaying.

I really like the control. Thanks for your work and for being willing to share it. Sometime I’d like to see the ability to provide a database connection string and query or a data connection file link, but this is really good.  

Paul

From: wictor [mailto:notifications@codeplex.com]
Sent: Tuesday, September 22, 2009 12:56 AM
To: Van Beek, Paul
Subject: Re: Red X where Chart should be [ChartPart:69631]

From: wictor

Ok,

first of all what did you change in web.config?

Second; verify that you have these lines in your web.config:

<add verb="*" path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral,PublicKeyToken=31bf3856ad364e35" validate="false" />
...
<add key="ChartImageHandler" value="storage=memory;timeout=20;" />

/WW

Read the full discussion online.

To add a post to this discussion, reply to this email (ChartPart@discussions.codeplex.com)

To start a new discussion for this project, email ChartPart@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Dec 13, 2010 at 4:42 PM

Hi Wictor,

I have got both the entries mentioned by you in the web.config file. But still the ChartPart doesnt get displayed properly and the Red X sign is still displayed.

Could you please help me with this ?

Regards,

Rahul

 

Dec 6, 2011 at 12:17 PM

even we are getting that red X button

The first, added inside the <system.web><httpHandlers></system.web></httpHandlers> tags below lines

<add path="ChartImg.axd" verb="GET,HEAD" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>

and

<add name="ChartImageHandler" preCondition="integratedMode" verb="GET,HEAD" path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> inside <system.webserver><handlers></system.webserver></handlers> tags.

but still we are getting this error.

We are struck here. Please help.