Error Installing

Feb 2, 2009 at 7:40 PM
I get this error when I install with the installer. I dont know where to go from here. 
Sharepoint 3.0 (SP1 I think)
.NET 3.5 (SP1)
Windows 2003 R2 SP2

Thanks!
Cris.







***** SOLUTION DEPLOYMENT *****
SRVHDQAP7 : http://serverdocument/ : ServerDocumentSite : Error: The copying of this file failed: feature.xml.
Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.
SRVHDQAP7 : Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.

***** ERROR *****
SRVHDQAP7 : http://serverdocument/ : ServerDocumentSite : Error: The copying of this file failed: feature.xml.
Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.
SRVHDQAP7 : Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.

CodePlex.SharePointInstaller.InstallException: SRVHDQAP7 : http://serverdocument/ : ServerDocumentSite : Error: The copying of this file failed: feature.xml.
Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.
SRVHDQAP7 : Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.
 ---> CodePlex.SharePointInstaller.InstallException: SRVHDQAP7 : http://serverdocument/ : ServerDocumentSite : Error: The copying of this file failed: feature.xml.
Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.
SRVHDQAP7 : Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.

   at CodePlex.SharePointInstaller.InstallProcessControl.WaitForJobCompletionCommand.Execute()
   --- End of inner exception stack trace ---
   at CodePlex.SharePointInstaller.InstallProcessControl.WaitForJobCompletionCommand.Execute()
   at CodePlex.SharePointInstaller.InstallProcessControl.TimerEventInstall(Object myObject, EventArgs myEventArgs)
***** SOLUTION RETRACTION *****
SRVHDQAP7 : http://serverdocument/ : ServerDocumentSite : Could not load type 'System.Web.HttpValidationStatus' from assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' due to value type mismatch.
ServerDocumentSite : Error: The removal of this file failed: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\Features\ChartPart\feature.xml.
Coordinator
Feb 2, 2009 at 8:50 PM
Please try a manual install and report back
/WW
Feb 2, 2009 at 8:54 PM
Wow! Thanks for the quick response! Here is the error I get when I get to the last stage.

C:\Documents and Settings\cbeagle>"C:\Program Files\Common Files\Microsoft Share
d\web server extensions\12\BIN\stsadm.exe" -o activatefeature -name ChartPart -u
rl http://serverdocument

Feature '12f7dd54-1bf1-46d8-9af0-6d6cf583ed88' is not installed in this farm, an
d can not be added to this scope.

Coordinator
Feb 2, 2009 at 10:32 PM
Did you really add the solution and then deploy it?
/WW
Feb 3, 2009 at 1:56 PM

I ran the commands listed in the manual installation instructions. Sorry, I'm a bit of a newbe when it comes to this.

Here are the instructions I followed


Run the following STSADM command: stsadm.exe -o addsolution -filename ChartPart.wsp
Run the following STSADM command: stsadm.exe -o execadmsvcjobs
Run the following STSADM command: stsadm.exe -o deploysolution -name ChartPart.wsp -immediate -allowgacdeployment -allcontenturls
Run the following STSADM command: stsadm.exe -o execadmsvcjobs
To Activate the feature run this STSADM command: stsadm -o activatefeature -name ChartPart -url <url to your site collection


Here is when I got when I ran those commands

C:\Documents and Settings\cbeagle>"C:\Program Files\Common Files\Microsoft Share
d\web server extensions\12\BIN\stsadm.exe" -o addsolution -filename ChartPart.ws
p

 

Operation completed successfully.

C:\Documents and Settings\cbeagle>"C:\Program Files\Common Files\Microsoft Share
d\web server extensions\12\BIN\stsadm.exe" -o execadmsvcjobs

Operation completed successfully.

C:\Documents and Settings\cbeagle>"C:\Program Files\Common Files\Microsoft Share
d\web server extensions\12\BIN\stsadm.exe" -o deploysolution -name ChartPart.wsp
 -immediate -allowgacdeployment -allcontenturls

Timer job successfully created.

C:\Documents and Settings\cbeagle>"C:\Program Files\Common Files\Microsoft Share
d\web server extensions\12\BIN\stsadm.exe" -o execadmsvcjobs

Operation completed successfully.

C:\Documents and Settings\cbeagle>"C:\Program Files\Common Files\Microsoft Share
d\web server extensions\12\BIN\stsadm.exe" -o activatefeature -name ChartPart -u
rl http://serverdocument

Feature '12f7dd54-1bf1-46d8-9af0-6d6cf583ed88' is not installed in this farm, an
d can not be added to this scope.

 

Coordinator
Feb 3, 2009 at 3:10 PM
Hi try this:
stsadm.exe -o deploysolution -name ChartPart.wsp -immediate -allowgacdeployment -url http://serverdocument
stsadm.exe -o execadmsvcjobs
stsadm.exe -o activatefeature -name ChartPart -url http://serverdocument
/WW
Feb 4, 2009 at 3:03 PM
After yet another reboot (thank you Micro$oft...) and some more goofin off, I got it working. I'm not sure what fixed it, I'm just going to accept it for now. Thanks for all your help!



Cris.
P.S. The installer works now.